summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..4f47962
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+# Must init the autoconf setup
+# The first parameter is project name
+# second is version number
+# third is bug report address
+AC_INIT([game],[0.0.1])
+
+# Safety checks in case user overwritten --srcdir
+AC_CONFIG_SRCDIR([src/game.c])
+
+# Store the auxiliary build tools (e.g., install-sh, config.sub, config.guess)
+# in this dir (build-aux)
+AC_CONFIG_AUX_DIR([build-aux])
+
+# Init automake, and specify this program use relaxed structures.
+# i.e. this program doesn't follow the gnu coding standards, and doesn't have
+# ChangeLog, COPYING, AUTHORS, INSTALL, README etc. files.
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects dist-xz])
+
+AC_PROG_CXX()
+# AC_PROG_CC([clang])
+
+# Set default cflags
+#: ${CFLAGS="-O3 -pedantic"}
+
+# Checks for header files.
+AC_CHECK_HEADERS([SDL2/SDL.h])
+
+# Tells automake to create a Makefile
+# See https://www.gnu.org/software/automake/manual/html_node/Requirements.html
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
+
+dnl AC_REQUIRE_AUX_FILE([tap-driver.sh])
+# Generate the output
+AC_OUTPUT