summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 95bbaf5..d92a287 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,21 @@
-TESTS = check_parse
-check_PROGRAMS = check_parse
-check_parse_SOURCES = check_parse.c $(top_builddir)/src/parse.h
-check_parse_CFLAGS = @CHECK_CFLAGS@
+# Setup TAP
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/build-aux/tap-driver.sh
+
+TESTS = foodtest
+
+EXTRA_DIST = maketests.sh \
+ foodtest.in \
+ types.c \
+ util.c
+
+check_PROGRAMS = foodtest
+
+# foodtest_SOURCES = foodtest.c $(top_builddir)/src/parse.h
+nodist_foodtest_SOURCES = foodtest.c
+foodtest_CFLAGS = @CHECK_CFLAGS@ -lcheck
+
+CLEANFILES = foodtest.c
+
+foodtest.c: $(top_srcdir)/tests/foodtest.in $(top_srcdir)/tests/*.c
+ $(top_srcdir)/tests/maketests.sh -i $(top_srcdir)/tests/foodtest.in -o foodtest.c