summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2022-05-10 21:12:33 +0300
committergramanas <anastasis.gramm2@gmail.com>2022-05-10 21:12:33 +0300
commit16538abf8d1231279133508ba15376145b818518 (patch)
treee19079645f87163f674faa333044330c37374ea9 /tests/Makefile.am
parente739c5dccc0faf13cbddacd1950e203305aa4bab (diff)
downloadfoodtools-16538abf8d1231279133508ba15376145b818518.tar.gz
foodtools-16538abf8d1231279133508ba15376145b818518.tar.bz2
foodtools-16538abf8d1231279133508ba15376145b818518.zip
autotools and check testign suite
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 95bbaf5..d92a287 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,21 @@
-TESTS = check_parse
-check_PROGRAMS = check_parse
-check_parse_SOURCES = check_parse.c $(top_builddir)/src/parse.h
-check_parse_CFLAGS = @CHECK_CFLAGS@
+# Setup TAP
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/build-aux/tap-driver.sh
+
+TESTS = foodtest
+
+EXTRA_DIST = maketests.sh \
+ foodtest.in \
+ types.c \
+ util.c
+
+check_PROGRAMS = foodtest
+
+# foodtest_SOURCES = foodtest.c $(top_builddir)/src/parse.h
+nodist_foodtest_SOURCES = foodtest.c
+foodtest_CFLAGS = @CHECK_CFLAGS@ -lcheck
+
+CLEANFILES = foodtest.c
+
+foodtest.c: $(top_srcdir)/tests/foodtest.in $(top_srcdir)/tests/*.c
+ $(top_srcdir)/tests/maketests.sh -i $(top_srcdir)/tests/foodtest.in -o foodtest.c