aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b1bc41..3808c3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,9 @@ project(ck C)
set(ck_MAJOR_VERSION 0)
set(ck_MINOR_VERSION 7)
+# c flags
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+
# options
option(CK_ASAN "Build with asan")
option(CK_DEBUG "Build with debug symbols")