aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2018-10-25 19:06:34 +0300
committergramanas <anastasis.gramm2@gmail.com>2018-10-25 19:06:34 +0300
commitc3267a360860de225fa0af666d99f60d03266249 (patch)
tree6d9db577082bec43074c07194d14ce9694754ce0 /CMakeLists.txt
parentd29c929e444d69ea7d4ce146f67f4c8df36baa95 (diff)
downloadck-c3267a360860de225fa0af666d99f60d03266249.tar.gz
ck-c3267a360860de225fa0af666d99f60d03266249.tar.bz2
ck-c3267a360860de225fa0af666d99f60d03266249.zip
Fix config parser bug
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b1bc41..3808c3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,9 @@ project(ck C)
set(ck_MAJOR_VERSION 0)
set(ck_MINOR_VERSION 7)
+# c flags
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+
# options
option(CK_ASAN "Build with asan")
option(CK_DEBUG "Build with debug symbols")