summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..91e1be5
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,33 @@
+#bin_PROGRAMS = food cookbook cook synth
+bin_PROGRAMS = synth
+
+common_sources = filter.c \
+ filter.h \
+ lowpass.c \
+ lowpass.h \
+ Makefile.am \
+ notes.h \
+ raygui.h \
+ synth_engine.c \
+ synth_engine.h \
+ synth_gui.c \
+ synth_gui.h \
+ synth_math.h
+
+# -fwhole-program allows cross-file inlining, but only works when you put all
+# the source files on one gcc command-line. -flto is another way to get the
+# same effect. (Link-Time Optimization). clang supports -flto but not
+# -fwhole-program.
+
+# If your program doesn't depend on strict FP rounding
+# behaviour, use -ffast-math. If it does, you can usually still use
+# -fno-math-errno and stuff like that, without enabling
+# -funsafe-math-optimizations. Some FP code can get big speedups from
+# fast-math, like auto-vectorization.
+AM_CFLAGS = -O3 -march=native -fno-math-errno -funroll-loops -flto
+
+synth_SOURCES = synth.c $(common_sources)
+synth_LDADD = -lportaudio -lrt -lm -lasound -lraylib
+#cookbook_SOURCES = cookbook.c $(common_sources)
+#cookbook_SOURCES = cookbook.c $(common_sources)
+#cook_SOURCES = cook.c $(common_sources)