summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 0 insertions, 54 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index ebf1d63..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,54 +0,0 @@
-# Must init the autoconf setup
-# The first parameter is project name
-# second is version number
-# third is bug report address
-AC_INIT([synth],[0.0.1])
-
-# Safety checks in case user overwritten --srcdir
-AC_CONFIG_SRCDIR([src/synth.c])
-
-# Store the auxiliary build tools (e.g., install-sh, config.sub, config.guess)
-# in this dir (build-aux)
-AC_CONFIG_AUX_DIR([build-aux])
-
-# Init automake, and specify this program use relaxed structures.
-# i.e. this program doesn't follow the gnu coding standards, and doesn't have
-# ChangeLog, COPYING, AUTHORS, INSTALL, README etc. files.
-AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects dist-xz])
-
-AC_PROG_CC
-
-#PKG_CHECK_MODULES([CHECK], [check >= 0.9.6])
-
-# Set default cflags
-#: ${CFLAGS="-O3 -pedantic"}
-
-# Checks for header files.
-dnl AC_CHECK_HEADERS([stdlib.h])
-AC_CHECK_HEADERS([raylib.h])
-AC_CHECK_HEADERS([portaudio.h])
-AC_CHECK_HEADERS([portmidi.h])
-
-dnl AC_CHECK_FUNCS([memset])
-dnl AC_CHECK_FUNCS([strcasecmp])
-dnl AC_CHECK_FUNCS([strdup])
-dnl AC_CHECK_FUNCS([strerror])
-dnl AC_CHECK_FUNCS([strstr])
-dnl AC_CHECK_FUNCS([strtol])
-dnl AC_CHECK_HEADERS([stdint.h])
-dnl #AC_FUNC_MALLOC
-dnl #AC_FUNC_REALLOC
-dnl AC_TYPE_INT32_T
-dnl AC_TYPE_SIZE_T
-dnl AC_TYPE_UINT32_T
-dnl AC_TYPE_UINT64_T
-dnl AC_TYPE_UINT8_T
-
-# Tells automake to create a Makefile
-# See https://www.gnu.org/software/automake/manual/html_node/Requirements.html
-AC_CONFIG_FILES([Makefile
- src/Makefile])
-
-dnl AC_REQUIRE_AUX_FILE([tap-driver.sh])
-# Generate the output
-AC_OUTPUT