summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2023-04-20 18:24:49 +0300
committergramanas <anastasis.gramm2@gmail.com>2023-04-20 18:24:49 +0300
commitc161e1016a04566a56b4858ea43502fed88dcc7f (patch)
treeb4b3086f000df6b63229dae6057f1aa253811b30 /src/Makefile.am
parent1e374b426b4182c7b73b35219aadaca267b9623c (diff)
downloadsynth-project-c161e1016a04566a56b4858ea43502fed88dcc7f.tar.gz
synth-project-c161e1016a04566a56b4858ea43502fed88dcc7f.tar.bz2
synth-project-c161e1016a04566a56b4858ea43502fed88dcc7f.zip
Add midi
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 91e1be5..3aff1d3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,8 @@ common_sources = filter.c \
lowpass.c \
lowpass.h \
Makefile.am \
+ midi.c \
+ midi.h \
notes.h \
raygui.h \
synth_engine.c \
@@ -24,10 +26,10 @@ common_sources = filter.c \
# -fno-math-errno and stuff like that, without enabling
# -funsafe-math-optimizations. Some FP code can get big speedups from
# fast-math, like auto-vectorization.
-AM_CFLAGS = -O3 -march=native -fno-math-errno -funroll-loops -flto
+AM_CFLAGS = -O3 -march=native -fno-math-errno -funroll-loops -flto -pthread
synth_SOURCES = synth.c $(common_sources)
-synth_LDADD = -lportaudio -lrt -lm -lasound -lraylib
+synth_LDADD = -lportaudio -lrt -lm -lasound -lraylib -lportmidi
#cookbook_SOURCES = cookbook.c $(common_sources)
#cookbook_SOURCES = cookbook.c $(common_sources)
#cook_SOURCES = cook.c $(common_sources)