summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2023-11-21 14:07:33 +0200
committergramanas <anastasis.gramm2@gmail.com>2023-11-21 14:07:33 +0200
commitc03d395f6848fe9b2d1185173a9cf5ec8277394f (patch)
tree2dad9fe79a189096b713559e35cf49497fea817a /src/Makefile.am
parenta7c39399e3ec051f210d9e991fe0112d0f988817 (diff)
downloadsynth-project-c03d395f6848fe9b2d1185173a9cf5ec8277394f.tar.gz
synth-project-c03d395f6848fe9b2d1185173a9cf5ec8277394f.tar.bz2
synth-project-c03d395f6848fe9b2d1185173a9cf5ec8277394f.zip
Crappy fft for spectrum analysis and initial gtk test
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e75352..45ac871 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
#bin_PROGRAMS = food cookbook cook synth
-bin_PROGRAMS = synth
+bin_PROGRAMS = synth gtk
common_sources = adsr.c \
adsr.h \
@@ -32,6 +32,8 @@ common_sources = adsr.c \
synth_gui.h \
synth_math.h
+gtk_sources =
+
# -fwhole-program allows cross-file inlining, but only works when you put all
# the source files on one gcc command-line. -flto is another way to get the
# same effect. (Link-Time Optimization). clang supports -flto but not
@@ -45,7 +47,11 @@ common_sources = adsr.c \
AM_CFLAGS = -O3 -march=native -fno-math-errno -funroll-loops -flto -pthread
synth_SOURCES = synth.c $(common_sources)
-synth_LDADD = -lportaudio -lrt -lm -lasound -lraylib -lportmidi -ljack -lfftw3f -lsndfile
+synth_LDADD = -lportaudio -lrt -lm -lasound -lraylib -lportmidi -ljack -lfftw3f -lsndfile -lconfig
+
+gtk_SOURCES = gtk.c $(common_sources) $(gtk_sources)
+gtk_LDADD = -lportaudio -lrt -lm -lasound -lraylib -lportmidi -ljack -lfftw3f -lsndfile -lconfig -lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgraphene-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
+gtk_CFLAGS = -I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-6 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -mfpmath=sse -msse -msse2 -pthread
#cookbook_SOURCES = cookbook.c $(common_sources)
#cookbook_SOURCES = cookbook.c $(common_sources)
#cook_SOURCES = cook.c $(common_sources)