aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/disko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/disko.nix')
-rw-r--r--scripts/disko.nix74
1 files changed, 74 insertions, 0 deletions
diff --git a/scripts/disko.nix b/scripts/disko.nix
new file mode 100644
index 0000000..6f2cc6f
--- /dev/null
+++ b/scripts/disko.nix
@@ -0,0 +1,74 @@
+{
+ disko.devices = {
+ nodev."/" = {
+ fsType = "tmpfs";
+ mountOptions = [
+ "defaults"
+ "size=16G"
+ "mode=755"
+ ];
+ };
+
+ disk.main = {
+ type = "disk";
+ device = "/dev/vda";
+
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ priority = 1;
+ size = "512M";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [
+ "defaults"
+ ];
+ };
+ };
+
+ luks = {
+ size = "100%";
+ content = {
+ type = "luks";
+ name = "crypted";
+ settings = {
+ allowDiscards = true;
+ };
+ content = {
+ type = "btrfs";
+ extraArgs = ["-f"];
+ subvolumes = {
+ nix = {
+ mountpoint = "/nix";
+ mountOptions = ["compress=zstd" "noatime"];
+ };
+ persist = {
+ mountpoint = "/persist";
+ mountOptions = ["compress=zstd" "noatime"];
+ };
+ log = {
+ mountpoint = "/var/log";
+ mountOptions = ["compress=zstd" "noatime"];
+ };
+ tmp = {
+ mountpoint = "/tmp";
+ mountOptions = ["noatime"];
+ };
+ swap = {
+ mountpoint = "/swap";
+ mountOptions = ["noatime"];
+ swap.swapfile.size = "32G";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}