aboutsummaryrefslogtreecommitdiffstats
path: root/nixos/user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/user.nix')
-rw-r--r--nixos/user.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixos/user.nix b/nixos/user.nix
new file mode 100644
index 0000000..00d4efe
--- /dev/null
+++ b/nixos/user.nix
@@ -0,0 +1,25 @@
+{pkgs, ...}: {
+ users.users = {
+ root = {
+ # inherit initialHashedPassword;
+ hashedPasswordFile = "/persist/passwordFiles/root";
+ };
+
+ grm = {
+ # inherit initialHashedPassword;
+ hashedPasswordFile = "/persist/passwordFiles/grm";
+ description = "grm";
+ isNormalUser = true;
+ extraGroups = ["wheel" "audio" "docker" "networkmanager"];
+ };
+ };
+
+ # Don't allow mutation of users outside of the config.
+ users.mutableUsers = false;
+
+ # programs.steam = {
+ # enable = true;
+ # remotePlay.openFirewall = true; # Open ports in the firewall for Steam Remote Play
+ # dedicatedServer.openFirewall = true; # Open ports in the firewall for Source Dedicated Server
+ # };
+}