aboutsummaryrefslogtreecommitdiffstats
path: root/overlays/default.nix
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2024-10-07 11:47:06 +0300
committergramanas <anastasis.gramm2@gmail.com>2024-10-07 11:47:06 +0300
commit4547e75868cba2a265b78661ddc386b5e81c1bb0 (patch)
tree71924feb573c8af5030080fc007eee7bfbaabb20 /overlays/default.nix
downloadnix-master.tar.gz
nix-master.tar.bz2
nix-master.zip
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
new file mode 100644
index 0000000..e1445f8
--- /dev/null
+++ b/overlays/default.nix
@@ -0,0 +1,16 @@
+# This file defines overlays
+{inputs, ...}: {
+ # This one brings our custom packages from the 'pkgs' directory
+ additions = final: _prev: import ../pkgs {pkgs = final;};
+
+ # This one contains whatever you want to overlay
+ modifications = final: prev: {
+ };
+
+ master-packages = final: _prev: {
+ master = import inputs.nixpkgs-master {
+ system = final.system;
+ config.allowUnfree = true;
+ };
+ };
+}