aboutsummaryrefslogtreecommitdiffstats
path: root/nixos/user.nix
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2024-10-07 11:47:06 +0300
committergramanas <anastasis.gramm2@gmail.com>2024-10-07 11:47:06 +0300
commit4547e75868cba2a265b78661ddc386b5e81c1bb0 (patch)
tree71924feb573c8af5030080fc007eee7bfbaabb20 /nixos/user.nix
downloadnix-4547e75868cba2a265b78661ddc386b5e81c1bb0.tar.gz
nix-4547e75868cba2a265b78661ddc386b5e81c1bb0.tar.bz2
nix-4547e75868cba2a265b78661ddc386b5e81c1bb0.zip
Diffstat (limited to 'nixos/user.nix')
-rw-r--r--nixos/user.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixos/user.nix b/nixos/user.nix
new file mode 100644
index 0000000..00d4efe
--- /dev/null
+++ b/nixos/user.nix
@@ -0,0 +1,25 @@
+{pkgs, ...}: {
+ users.users = {
+ root = {
+ # inherit initialHashedPassword;
+ hashedPasswordFile = "/persist/passwordFiles/root";
+ };
+
+ grm = {
+ # inherit initialHashedPassword;
+ hashedPasswordFile = "/persist/passwordFiles/grm";
+ description = "grm";
+ isNormalUser = true;
+ extraGroups = ["wheel" "audio" "docker" "networkmanager"];
+ };
+ };
+
+ # Don't allow mutation of users outside of the config.
+ users.mutableUsers = false;
+
+ # programs.steam = {
+ # enable = true;
+ # remotePlay.openFirewall = true; # Open ports in the firewall for Steam Remote Play
+ # dedicatedServer.openFirewall = true; # Open ports in the firewall for Source Dedicated Server
+ # };
+}