summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e7ff39d..704b0e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
AC_INIT([foodtools], [0.0.1])
# Safety checks in case user overwritten --srcdir
-# AC_CONFIG_SRCDIR([src/food.c])
+AC_CONFIG_SRCDIR([src/food.c])
# Store the auxiliary build tools (e.g., install-sh, config.sub, config.guess)
# in this dir (build-aux)
@@ -16,6 +16,9 @@ AC_CONFIG_AUX_DIR([build-aux])
# ChangeLog, COPYING, AUTHORS, INSTALL, README etc. files.
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects dist-xz])
+# Set default cflags
+: ${CFLAGS="-O3 -pedantic"}
+
# Check for C compiler
AC_PROG_CC
# We can add more checks in this section