aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ed42c6..bb03dfb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ configure_file(
"${SRC_DIR}/ckinfo.h"
)
+# configure the manpage
+configure_file(
+ "ck.1"
+ "${CMAKE_BINARY_DIR}/ck.1"
+ )
+
# Set source code locations
set(ckBin_src ${SRC_DIR}/ck.c)
set(ckUnitTest_src ${UNIT_TEST_DIR}/ck-test.c)
@@ -102,6 +108,7 @@ target_link_libraries(ck ckLib)
target_link_libraries(ck ${SQLITE3_LIBRARIES})
install(TARGETS ck DESTINATION bin)
+install(FILES ${CMAKE_BINARY_DIR}/ck.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
if (CK_TESTS)
## unit test