aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2018-08-14 14:36:55 +0300
committergramanas <anastasis.gramm2@gmail.com>2018-08-14 14:36:55 +0300
commitffc33043a488ecf038d8414fc8af1e99389619f8 (patch)
tree7b1db10e7870735a4b539944d1952b4788a3cbb0 /CMakeLists.txt
parent68efbf97390ddac355c3b54a5d825e74fb4b208d (diff)
downloadck-ffc33043a488ecf038d8414fc8af1e99389619f8.tar.gz
ck-ffc33043a488ecf038d8414fc8af1e99389619f8.tar.bz2
ck-ffc33043a488ecf038d8414fc8af1e99389619f8.zip
CmakeLists nits
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 088ce3b..1d1b628 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-## actionparser.c - Action parser for ck -------------------------------*- C -*-
+## CMakeLists.txt - Build recipe -----------------------------------*- CMake -*-
##
## This file is part of ck, the config keeper
##
@@ -11,16 +11,16 @@
cmake_minimum_required (VERSION 3.5.6)
project(ck C)
-
set(CMAKE_C_COMPILER clang)
-# gcc flags
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g3")
-
option(CK_ASAN "Build with asan")
+# compiler flags
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g3")
+
if(CK_ASAN)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=address")
endif(CK_ASAN)
+
# Set project directories
set(SRC_DIR ${CMAKE_CURRENT_SOURCE_DIR}/src)
set(RES_DIR ${CMAKE_CURRENT_SOURCE_DIR}/res)