summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2024-06-17 17:01:26 +0300
committergramanas <anastasis.gramm2@gmail.com>2024-06-17 17:01:26 +0300
commitf193bf8013b75dd78fc37ddcfc73b854340649a5 (patch)
treeadae823721b118e851223e220da81bbc53cf9f3c /src/Makefile.am
parent40fbb328150d853d0d7a83ce447c3f008de38822 (diff)
downloadcgame-f193bf8013b75dd78fc37ddcfc73b854340649a5.tar.gz
cgame-f193bf8013b75dd78fc37ddcfc73b854340649a5.tar.bz2
cgame-f193bf8013b75dd78fc37ddcfc73b854340649a5.zip
rm autotools
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am29
1 files changed, 0 insertions, 29 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index d2f2f8f..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,29 +0,0 @@
-bin_PROGRAMS = game
-
-common_sources = state.h
-
-debug_flags = -O2 -DVKDEBUG
-release_flags = -O3
-common_flags = $(release_flags) -Wall -Wextra -march=native -fno-math-errno -funroll-loops -flto -pthread -ggdb -Wno-string-plus-int
-
-AM_LDFLAGS = -fuse-ld=lld -flto
-
-# -fwhole-program allows cross-file inlining, but only works when you put all
-# the source files on one gcc command-line. -flto is another way to get the
-# same effect. (Link-Time Optimization). clang supports -flto but not
-# -fwhole-program.
-
-# If your program doesn't depend on strict FP rounding
-# behaviour, use -ffast-math. If it does, you can usually still use
-# -fno-math-errno and stuff like that, without enabling
-# -funsafe-math-optimizations. Some FP code can get big speedups from
-# fast-math, like auto-vectorization.
-AM_CFLAGS = $(common_flags)
-# AM_CFLAGS = -O0 -march=native -fno-math-errno -funroll-loops -flto -pthread -ggdb -fsanitize=address
-
-AM_CXXFLAGS = $(common_flags) -std=c++17
-
-game_SOURCES = render.c cplusplus.cpp $(common_sources)
-game_LDADD = -lSDL2 -lm -lvulkan -lshaderc_shared -lstdc++
-
-cplusplus.$(OBJEXT) : CXXFLAGS += -Wno-nullability-completeness -Wno-unused-function -Wno-missing-field-initializers -Wno-unused-parameter -Wno-unused-variable