summaryrefslogtreecommitdiffstats
path: root/lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2024-06-05 19:04:25 +0300
committergramanas <anastasis.gramm2@gmail.com>2024-06-05 19:04:25 +0300
commita6501b5d7ad204c3b998c843c7ed68ef7be323ba (patch)
tree1a442e6095abf160e36baa31a319858774cd1178 /lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt
parent6af7e785890a322f60c21a51e3d41cd9015e6773 (diff)
downloadcgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.tar.gz
cgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.tar.bz2
cgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.zip
more vks, stupid mutlistep build, and imgui
Diffstat (limited to 'lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt')
-rw-r--r--lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt b/lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt
new file mode 100644
index 0000000..a6e5bf9
--- /dev/null
+++ b/lib/imgui-1.90.7/examples/example_glfw_vulkan/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Example usage:
+# mkdir build
+# cd build
+# cmake -g "Visual Studio 14 2015" ..
+
+cmake_minimum_required(VERSION 2.8)
+project(imgui_example_glfw_vulkan C CXX)
+
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Debug CACHE STRING "" FORCE)
+endif()
+
+set(CMAKE_CXX_STANDARD 11)
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DVK_PROTOTYPES")
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DVK_PROTOTYPES")
+
+# GLFW
+set(GLFW_DIR ../../../glfw) # Set this to point to an up-to-date GLFW repo
+option(GLFW_BUILD_EXAMPLES "Build the GLFW example programs" OFF)
+option(GLFW_BUILD_TESTS "Build the GLFW test programs" OFF)
+option(GLFW_BUILD_DOCS "Build the GLFW documentation" OFF)
+option(GLFW_INSTALL "Generate installation target" OFF)
+option(GLFW_DOCUMENT_INTERNALS "Include internals in documentation" OFF)
+add_subdirectory(${GLFW_DIR} binary_dir EXCLUDE_FROM_ALL)
+include_directories(${GLFW_DIR}/include)
+
+# Dear ImGui
+set(IMGUI_DIR ../../)
+include_directories(${IMGUI_DIR} ${IMGUI_DIR}/backends ..)
+
+# Libraries
+find_package(Vulkan REQUIRED)
+#find_library(VULKAN_LIBRARY
+ #NAMES vulkan vulkan-1)
+#set(LIBRARIES "glfw;${VULKAN_LIBRARY}")
+set(LIBRARIES "glfw;Vulkan::Vulkan")
+
+# Use vulkan headers from glfw:
+include_directories(${GLFW_DIR}/deps)
+
+file(GLOB sources *.cpp)
+
+add_executable(example_glfw_vulkan ${sources} ${IMGUI_DIR}/backends/imgui_impl_glfw.cpp ${IMGUI_DIR}/backends/imgui_impl_vulkan.cpp ${IMGUI_DIR}/imgui.cpp ${IMGUI_DIR}/imgui_draw.cpp ${IMGUI_DIR}/imgui_demo.cpp ${IMGUI_DIR}/imgui_tables.cpp ${IMGUI_DIR}/imgui_widgets.cpp)
+target_link_libraries(example_glfw_vulkan ${LIBRARIES})
+target_compile_definitions(example_glfw_vulkan PUBLIC -DImTextureID=ImU64)