summaryrefslogtreecommitdiffstats
path: root/lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle
diff options
context:
space:
mode:
authorgramanas <anastasis.gramm2@gmail.com>2024-06-05 19:04:25 +0300
committergramanas <anastasis.gramm2@gmail.com>2024-06-05 19:04:25 +0300
commita6501b5d7ad204c3b998c843c7ed68ef7be323ba (patch)
tree1a442e6095abf160e36baa31a319858774cd1178 /lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle
parent6af7e785890a322f60c21a51e3d41cd9015e6773 (diff)
downloadcgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.tar.gz
cgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.tar.bz2
cgame-a6501b5d7ad204c3b998c843c7ed68ef7be323ba.zip
more vks, stupid mutlistep build, and imgui
Diffstat (limited to 'lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle')
-rw-r--r--lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle46
1 files changed, 46 insertions, 0 deletions
diff --git a/lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle b/lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle
new file mode 100644
index 0000000..53181ba
--- /dev/null
+++ b/lib/imgui-1.90.7/examples/example_android_opengl3/android/app/build.gradle
@@ -0,0 +1,46 @@
+apply plugin: 'com.android.application'
+apply plugin: 'kotlin-android'
+
+android {
+ compileSdkVersion 33
+ buildToolsVersion "33.0.2"
+ ndkVersion "25.2.9519653"
+
+ defaultConfig {
+ applicationId "imgui.example.android"
+ namespace "imgui.example.android"
+ minSdkVersion 24
+ targetSdkVersion 33
+ versionCode 1
+ versionName "1.0"
+ }
+
+ buildTypes {
+ release {
+ minifyEnabled false
+ proguardFiles getDefaultProguardFile('proguard-android-optimize.txt')
+ }
+ }
+
+ compileOptions {
+ sourceCompatibility JavaVersion.VERSION_11
+ targetCompatibility JavaVersion.VERSION_11
+ }
+
+ kotlinOptions {
+ jvmTarget="11"
+ }
+
+ externalNativeBuild {
+ cmake {
+ path "../../CMakeLists.txt"
+ version '3.22.1'
+ }
+ }
+}
+repositories {
+ mavenCentral()
+}
+dependencies {
+ implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
+}