aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65490cc..c0700c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ project(ck C)
# version
set(ck_MAJOR_VERSION 0)
set(ck_MINOR_VERSION 9)
-set(ck_PATCH_VERSION 2)
+set(ck_PATCH_VERSION 3)
# Feature test macros
set(FEATURE_TEST_MACROS "-D_DEFAULT_SOURCE")
@@ -56,7 +56,6 @@ set(ckBin_src ${SRC_DIR}/ck.c)
set(ckUnitTest_src ${UNIT_TEST_DIR}/ck-test.c)
set(ckLib_src
${SRC_DIR}/clparser.c
- ${SRC_DIR}/actions.c
${SRC_DIR}/confparser.c
${SRC_DIR}/dblayer.c
${SRC_DIR}/queries.c
@@ -69,6 +68,8 @@ set(ckLib_src
${SRC_DIR}/edit.c
${SRC_DIR}/list.c
${SRC_DIR}/restore.c
+ ${SRC_DIR}/search.c
+ ${SRC_DIR}/help.c
)
set(ckLib_hdr
@@ -120,15 +121,14 @@ if (CK_TESTS)
target_link_libraries(ck-test ckLib)
target_link_libraries(ck-test ${SQLITE3_LIBRARIES})
- # copy test files
+ ## copy test files
set(BIN_TEST_DIR ${CMAKE_BINARY_DIR}/res/test)
- set(PROJECT_TESTING_GROUNDS ${CMAKE_BINARY_DIR}/test_files)
- configure_file(${TEST_DIR}/00_init ${BIN_TEST_DIR}/00_init @ONLY)
- configure_file(${TEST_DIR}/01_add ${BIN_TEST_DIR}/01_add @ONLY)
- configure_file(${TEST_DIR}/02_list ${BIN_TEST_DIR}/02_list @ONLY)
- configure_file(${TEST_DIR}/03_delete ${BIN_TEST_DIR}/03_delete @ONLY)
- configure_file(${TEST_DIR}/04_search ${BIN_TEST_DIR}/04_search @ONLY)
- configure_file(${TEST_DIR}/05_restore ${BIN_TEST_DIR}/05_restore @ONLY)
+ set(PROJECT_TESTING_GROUNDS ${CMAKE_BINARY_DIR}/test_files) # used in the tests
+ file(GLOB files "${TEST_DIR}/*")
+ foreach(file ${files})
+ get_filename_component(BASENAME ${file} NAME)
+ configure_file(${file} ${BIN_TEST_DIR}/${BASENAME} @ONLY)
+ endforeach()
# test-ck
configure_file(${RES_DIR}/test-ck test-ck @ONLY)
endif()