aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e38e8e2..fe0934c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,13 @@
+## actionparser.c - Action parser for ck -------------------------------*- C -*-
+##
+## This file is part of ck, the config keeper
+##
+## -----------------------------------------------------------------------------
+##
+## Copyright (C) 2018 Anastasis Grammenos
+## GPLv3 (see LICENCE for the full notice)
+##
+## -------------------------------------------------------------------------- */
cmake_minimum_required (VERSION 3.5.6)
project(ck C)
@@ -22,19 +32,23 @@ set(ckLib_src
${SRC_DIR}/ck.c
${SRC_DIR}/actionparser.c
${SRC_DIR}/actions.c
+ ${SRC_DIR}/actionhelper.c
${SRC_DIR}/confparser.c
${SRC_DIR}/dblayer.c
${SRC_DIR}/dbhelper.c
${SRC_DIR}/ckutil.c
+ ${SRC_DIR}/cklist.c
${SRC_DIR}/engine.c
)
set(ckLib_hdr
${SRC_DIR}/actionparser.h
${SRC_DIR}/actions.h
+ ${SRC_DIR}/actionhelper.h
${SRC_DIR}/confparser.h
${SRC_DIR}/dblayer.h
${SRC_DIR}/dbhelper.h
${SRC_DIR}/ckutil.h
+ ${SRC_DIR}/cklist.h
${SRC_DIR}/engine.h
)